Monday, May 10, 2010

CentOS DomU on Debian
Discussion going on here

and here nothing came till now

Some one mentioned to do it

A relevant thread is

Another installation method which seems not to give error

xen-create-image --hostname=ocw --size=96GB --swap=2048 Mb --ip= --memory=1024 --arch=amd64 --role=udev --force --install-method=rinse --install-source=/root/inscd/
Most probably when you delete an existing VM and create a new with same name LVM shows that it is no more infact that is what is causing problems.So to my surprise change of name had worked.

Problem in configuring VNC

Now finally we are moving to QEMU vnc thing had failed
using QEMU and pygrub etc etc

These are snapshots of running QEMU

The installation was very slow so I had to finally kill because in 2 hours only 20% of it was installed some one suggested to use kqemu.

This article
did not worked for me.
Trying this one

Some snapshots of all the process.

Finally to be able to boot from QEMU on SSH
I did
qemu-system-x86_64  -hda /dev/virtualization/centos5-disk -hdb
/dev/virtualization/centos5-swap -m 1024 -boot c -net nic -net tap                 

A strange problem using QEMU

I am facing one more problem during the installation.If I press a key
once after some time I see the effect in QEMU screen there is some
delay and after this delay the effect of pressing the key is as if I
have clicked multiple times.Say
I have to enter the gateway address
If I press 9 or any of the above digit once
rather than typing
it types
199999999999999999 and then after some time it releases the cursor to
type any thing.
to choose between two menu
---> press cancel
 yes  no
If I choose yes it clicks many times automatically yes and goes back
to previous menu and then comes again to forward menu so back and
forth switching between menus.
Which makes it very difficult to move ahead it has been two hours but
I could not proceed at all with this.
More over the response is coming very slow if pressing any key stroke
from my laptop because of which I have to wait for a long time to get
the response and move to another menu.

I am not using the GUI based installer it is a text based install.If I
use a GUI  it is very very slow and have to wait for a very long time
for the response to come.
For example clicking on License agreement you agree yes
to do so it takes a very long time which it is not taking in text mode
but the above problem of seeing the effect multiple times in an
undesired way and slow response is there.
This is not a consistent situation but occurring at irregular
intervals.This has made my work very slow.
Is there any way to get rid of this?

Did this with KQEMU
After all the above experiments failed we finally moved to virsh

Now a nonsense blog made my work difficult.Later on problem was resolved.

No comments: